User Tools

Site Tools


how_to:upgrade_vpop3_to_version_7

Differences

This shows you the differences between two versions of the page.

Link to this comparison view

Next revision
Previous revision
how_to:upgrade_vpop3_to_version_7 [2016/11/08 09:00]
paul created
how_to:upgrade_vpop3_to_version_7 [2020/06/29 11:43] (current)
paul
Line 1: Line 1:
 ======How to upgrade VPOP3 to version 7 or later from version 6 or earlier====== ======How to upgrade VPOP3 to version 7 or later from version 6 or earlier======
 +
 +As usual the process to upgrade is simply to install the later version over your existing installation (do not uninstall anything first). The below is technical information detailing an extra step performed by the installer in this particular upgrade step.
 +
  
 VPOP3 version 5-6 use PostgreSQL 9.1 as the database backend. PostgreSQL 9.1 was marked EOL (End-of-life) in September 2016. It still works fine, so there will be no problems continuing to use it in VPOP3 versions 5-6, but we decided to use a later version of PostgreSQL in later versions of VPOP3, both for continuing support & bugfixes and for newer features that are available in later versions of PostgreSQL. VPOP3 version 5-6 use PostgreSQL 9.1 as the database backend. PostgreSQL 9.1 was marked EOL (End-of-life) in September 2016. It still works fine, so there will be no problems continuing to use it in VPOP3 versions 5-6, but we decided to use a later version of PostgreSQL in later versions of VPOP3, both for continuing support & bugfixes and for newer features that are available in later versions of PostgreSQL.
  
-So, VPOP3 version 7 uses PostgreSQL 9.5 as the database backend. (We chose not to use 9.6 because that is too new)+So, VPOP3 version 7 uses PostgreSQL 9.5 as the database backend. (We chose not to use 9.6 because that was too new when VPOP3 v7.0 was released)
  
 You cannot just replace the executable files to upgrade PostgreSQL. You need to upgrade the database files as well. You cannot just replace the executable files to upgrade PostgreSQL. You need to upgrade the database files as well.
Line 20: Line 23:
  
 The pg_upgrade process does not use much more disk space than the database already uses, so it should be possible to do this on most installations. It typically takes 5-10 minutes. The pg_upgrade process does not use much more disk space than the database already uses, so it should be possible to do this on most installations. It typically takes 5-10 minutes.
 +
 +
 +=====64 bit version=====
 +Starting with VPOP3 v7.1 we are also releasing a 64 bit version of VPOP3. To upgrade to the 64 bit version, you must previously have been running v5 or later. ​
 +
 +The 64 bit version of VPOP3 does not include some library components which are needed to read data from v4 or earlier, so if you upgrade from v4 or earlier to 64 bit v7.1, then you may lose some data during the upgrade. So, if you are using VPOP3 v4 or earlier, we recommend upgrading to a recent 32 bit version of VPOP3 and run that for a week or two to let it complete any background data migration, then upgrade to the 64 bit version of VPOP3 if you wish.
 +
 +The 64 bit version also lacks some features of the 32 bit version:
 +  * The Webmail interface doesn'​t have a spell checker
 +  * Sophos SAV Interface (SAVI) does not work
 +
 +=====Problems during upgrade=====
 +We recommend that if you have any problems during the upgrade, you contact us immediately (01484 855800). Do not try to '​fix'​ it yourself unless you are sure of what you are doing (and have a known-good recent backup), as that will often cause even more problems. We do not charge for problems that occur during the upgrade or installation process.
 +
 +====Error 1031 during installing the database====
 +
 +Check that the password for the Windows user '​vpop3postgres'​ in Windows is set to **Nc6ACboDt2jVL6**. This is the default since version 5 was released, but sometimes people have changed this. The installer needs to run some programs as the vpop3postgres user, so it needs to know the password. If the password for this user has been changed, then it will be unable to run the programs as this user. 
 +
 +**Do not abort the VPOP3 installation!** Instead reset the password in Windows, then tell the installer to retry the operation
 +
 +====If you do abort the installation====
 +If you abort the installation for any reason, before the '​pg_upgrade'​ window has appeared as described above, then it is possible the database folder has been renamed so the database will not work.
 +
 +To put back the old database, you need to rename some folders and reinstall VPOP3 version 6.x
 +
 +  - Stop the VPOP3 and VPOP3DB services in Windows (if they are running)
 +  - Rename the **VPOP3\pgsql** folder to '​pgsql_old'​ (or similar)
 +  - Rename the **VPOP3\pgsql91_v7upg** folder to **pgsql**
 +  - Reinstall VPOP3 version 6.20
  
  
how_to/upgrade_vpop3_to_version_7.1478595637.txt.gz ยท Last modified: 2018/11/14 10:44 (external edit)