User Tools

Site Tools


how_to:install_postgresql_manually

Differences

This shows you the differences between two versions of the page.

Link to this comparison view

Next revision
Previous revision
how_to:install_postgresql_manually [2011/10/10 14:25]
paul created
how_to:install_postgresql_manually [2018/11/14 10:45] (current)
Line 3: Line 3:
 VPOP3 version 3.x and later require a PostgreSQL installation to be able to work. For most users, the installer will automatically install PostgreSQL on the same PC as VPOP3 and configure it appropriately,​ but this article explains how to manually install and configure PostgreSQL for advanced users who may want install it differently (eg on a different PC or drive) or if you are having problems using the normal installer. VPOP3 version 3.x and later require a PostgreSQL installation to be able to work. For most users, the installer will automatically install PostgreSQL on the same PC as VPOP3 and configure it appropriately,​ but this article explains how to manually install and configure PostgreSQL for advanced users who may want install it differently (eg on a different PC or drive) or if you are having problems using the normal installer.
  
-VPOP3 versions 3 or 4 require PostgreSQL 8.3 or later. VPOP3 version 5 will require ​PostgreSQL 9.or later. So, it may be best to install PostgreSQL 9.1 if you are installing manually, to avoid the need for a database server upgrade if you upgrade to VPOP3 version 5 later. (There are no known incompatibilities between VPOP3 versions 3-and PostgreSQL 9.1 - later versions of PostgreSQL may introduce incompatibilities)+VPOP3 versions 3 or 4 require PostgreSQL 8.3 or later. VPOP3 version 5 requires ​PostgreSQL 9.or later. So, it may be best to install PostgreSQL 9.1 if you are installing manually, to avoid the need for a database server upgrade if you upgrade to VPOP3 version 5 later. (There are no known incompatibilities between VPOP3 versions 3-and PostgreSQL 9.1 - later versions of PostgreSQL may introduce incompatibilities)
  
 Download the relevant version of PostgreSQL from http://​www.enterprisedb.com/​products-services-training/​pgdownload#​windows - note that VPOP3 will work with either the 32 or 64 bit versions of PostgreSQL, although the standard distribution distributes the 32 bit version. You can use whichever version you wish. Download the relevant version of PostgreSQL from http://​www.enterprisedb.com/​products-services-training/​pgdownload#​windows - note that VPOP3 will work with either the 32 or 64 bit versions of PostgreSQL, although the standard distribution distributes the 32 bit version. You can use whichever version you wish.
Line 17: Line 17:
  
 Finally, you need to create a user and database for VPOP3 to use. Finally, you need to create a user and database for VPOP3 to use.
-  - Go to Start -> Programs -> PostgreSQL 9.1 -> pgAdmin III+  - Go to Start -> Programs -> PostgreSQL 9.1 -> pgAdmin III (assuming you installed PostgreSQL 9.1. If you installed a different version, the path may be different)
   - Right-click the **PostgreSQL Database Server 9.1 (Local)** in the left pane, and choose **Connect**   - Right-click the **PostgreSQL Database Server 9.1 (Local)** in the left pane, and choose **Connect**
   - In the **Connect to Server** box enter the password you defined in step 3 above (eg ''​pgsqlpass''​) and press **OK**   - In the **Connect to Server** box enter the password you defined in step 3 above (eg ''​pgsqlpass''​) and press **OK**
how_to/install_postgresql_manually.txt ยท Last modified: 2018/11/14 10:45 (external edit)